Internet Explorer Cumulative Security Patch Released

If the Web browser you use is Microsoft Internet Explorer (versions 5.01, 5.5 or 6.0), unauthorized persons may be able to gain control of your computer. Users of these Web browsers are advised to immediately download and install the recently announced critical security patch. This patch will install previous Internet Explorer Web browser security patches released by Microsoft and correct two new security vulnerabilities.